auto

jekyll build したところ、以下のエラーが出てビルドに失敗しました。

ERROR: YOUR SITE COULD NOT BE BUILT:
       ------------------------------------
       Invalid date '0000-00-00': Post '/vendor/bundle/ruby/2.1.0/gems/jekyll-2.5.3/lib/site_template/_posts/0000-00-00-welcome-to-jekyll.markdown.erb' does not have a valid date in the filename.

どうやら vendor/bundle 以下もビルドしようとしているようです。

_config.ymlexclude: [(パス)] を記述すると、そのパスをビルド対象から外れます。なので、exclude: [vendor] とすると解決します。

参考

invalid date '0000-00-00' from template · Issue #2938 · jekyll/jekyll